Installation Help

System Requirements

Unless otherwise specified, extensions from AE Creations require Mozilla Firefox, version 24 or newer. Older versions are not supported.

Clippings is compatible with Mozilla Firefox and Mozilla Thunderbird. You must download and install Clippings in Firefox and Thunderbird if you want to use Clippings in both programs; installing Clippings in one program will not install it in the other. To install Clippings in Thunderbird, follow the instructions in the Mozilla Thunderbird FAQ.

Allowing Extension Installation

If you see a warning popup panel at the top of your browser after clicking the install link, do the following:

  1. Click the Allow button in the popup.
  2. In the dialog box that appears, click Install to proceed with the extension installation.